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Fluid Dynamics Models : Flow Past a Cylinder

Flow Past a Cylinder

The flow of fluid behind a blunt body such as an automobile is difficult to compute due to the unsteady
flows. The wake behind such a body consists of unordered eddies of all sizes that create large drag on
the body. In contrast, the turbulence in the thin boundary layers next to the streamlined bodies of
aircraft and fish create only weak disturbances of flow.

An exception to this occurs when you place a slender body at right angles to a slow flow because the
eddies organize. A von Karman vortex street appears with a predictable frequency, and it involves the
shedding of eddies from alternating sides. Everyday examples of this phenomenon include singing
telephone wires and an automobile radio antenna vibrating in an air stream.

From an engineering standpoint, it is important to predict the frequency of vibrations at various fluid
speeds and thereby avoid undesirable resonances between the vibrations of the solid structures and the
vortex shedding. To help reduce such effects, plant engineers put a spiral on the upper part of high
smokestacks; the resulting variation in shape prohibits the constructive interference of the vortex
elements that the structure sheds from different positions.

Model Definition

To illustrate how you can study such effects, the following model examines unsteady, incompressible
flow past a long cylinder placed in a channel at right angle to the oncoming fluid. The cylinder is offset
somewhat from the center of the flow to destabilize what otherwise would be steady-state symmetrical
flow. The simulation time necessary for a periodic flow pattern to appear is difficult to predict. A key
predictor is the Reynolds number, which is based on cylinder diameter. For low values—below 100—the
flow is steady. In this simulation, the Reynolds number equals 100, which gives a developed Karman
vortex street, but the flow still is not fully turbulent.

The frequency and amplitude of oscillations are stable features, but flow details are extremely sensitive
to perturbations. To gain an appreciation for this sensitivity, you can compare flow images taken at the
same time but with such minor differences as are created by different tolerances for the time stepping.
It is important to note that this sensitivity is a physical reality and not simply a numerical artifact.

Before calculating the time-varying forces on the cylinder, you can validate the method of computation
at a lower Reynolds number using the direct nonlinear solver. This saves time because you can find and
correct simple errors and mistakes before the final time-dependent simulation, which requires
considerable time.

The viscous forces on the cylinder are proportional to the gradient of the velocity field at the cylinder
surface. Evaluating the velocity gradient on the boundary by directly differentiating the FEM solution is
possible but not very accurate. The differentiation produces 1st-order polynomials when 2nd-order
elements are used for the velocity field. A far better approach is to use a pair of weak-constraint
variables to enforce the no-slip condition; at the same time they collect 2nd-order accurate information
on the viscous forces.

The drag and lift forces themselves are not as interesting as the dimensionless drag and lift coefficients.
These depend only on the Reynolds number and an object’s shape, not its size. The coefficients are
defined as
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using the following parameters:

» Fpand F; are the drag and lift forces

e pis the fluid’s density

U, ean 1S the mean velocity

e D is the characteristic length, in this case the cylinder’s diameter

Results
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Figure 6-1 shows the flow pattern resulting from the geometry.

Nme=7  Surface: Valacity field [m/s] Man: 2,232

f 2

1|

1

; F{L5
05|

:|®"\J"'ﬂ-r'

| Pl

ol

: 0.5
-0.5

"0
o 0.5 1 L5 2 Min: O

Figure 6-1: A plot of the last time step clearly shows the von Karman path.

The flow around a cylinder is a common benchmark test for CFD algorithms. Various research teams
have tried their strengths on this problem using different techniques. Results from some of these
experiments have been collected by Schédfer and Turek (Ref. 1), who also use them to compute a
probable value for the “real” answer.

Reference

1. M. Schafer and S. Turek, “Benchmark computations of laminar flow around cylinder”, E.H. Hirschel
(editor), Flow Simulation with High-Performance Computers II, Volume 52 of Notes on Numerical Fluid
Mechanics, Vieweg, 1996, pp. 547-566.

Model Library Path: coMSOL_Multiphysics/Fluid_Dynamics/cylinder_flow

Modeling Using the Graphical User Interface

MODEL NAVIGATOR

1 In the Model Navigator, select 2D from the Space dimension list.

2 In the list of application modes, select
COMSOL Multiphysics>Fluid Dynamics>Incompressible Navier-Stokes, Steady-state

analysis. Accept the default entry in the Element list, Lagrange - P2 P1 elements.

3 Click OK.

OPTIONS AND SETTINGS

1 From the Options menu, select Axes/Grid Settings.

2 In the Axes/Grid Settings dialog box, specify the following settings. To enter the grid spacing, first
click the Grid tab and clear the Auto check box.

AXIS GRID
x min |-0.3 |x 0.2
spacing

X max |[2.5 |Extra x

y min |-0.3 |y 0.05
spacing
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|ymax|0-7 |Extray |0-4l|

3 Click OK.
4 From the Options menu, select Constants.

5 Enter the following names and expressions:

NAME | EXPRESSION

rho0 1

etal le-3

Umax [0.3

6 Click OK.

These values together with the cylinder having a diameter of 0.1 m lead to a Reynolds number of 20.

GEOMETRY MODELING

1 From the Draw menu, select the Rectangle/Square button. With the mouse, create a rectangle R1
from (0, 0) to (2.2, 0.41).

2 From the Draw menu, select the Ellipse/Circle (Centered) button. Using the mouse, create a circle
C1 with center at (0.2, 0.2) and a radius of 0.05. Use the right mouse button to ensure that you are
creating a circle, and use the tick mark at y = 0.15 to obtain the correct radius.

3 Create the composite object. From the Draw toolbar, click the Create Composite Object button. In
the Set formula edit field enter R1-C1.
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Click OK.

PHYSICS SETTINGS

Application Mode Properties
You must first enable the weak constraints in the Application Mode Properties dialog box.

1 From the Physics menu, choose Properties.

2 In the Application Mode Properties dialog box, go to the Weak constraints list and select Non-
ideal.

3 Click OK.

Boundary Conditions

First set the boundary conditions for the Incompressible Navier-Stokes equations as if the weak
constraints did not exist. When you couple a constraint variable to a dependent variable inside the
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domain, the weak constraint mode analyzes the constraints specified for the domain variable and
replaces them with a weak term involving the constraint variable.

1 From the Physics menu, choose Boundary Settings.

2 In the Boundary Settings dialog box, enter the following:

BOUNDARY|1 2,3 |4
5-8

Type Inflow No- Outflow
slip

u 4*Umax*s* (1-

s)
v 0
p 0

3 Click the Weak Constr. tab.
4 Select boundaries 1-4 (the channel boundaries) and clear the Use weak constraints check box.

5 Click OK.

Subdomain Settings

1 From the Physics menu, select Subdomain Settings.

2 In the Subdomain Settings dialog box, enter the following material properties:

SUBDOMAIN|1

o rho0
n etal
3 Click OK.

MESH GENERATION

1 From the Mesh menu, choose Free Mesh Parameters.

2 Click the Custom mesh size button, enter 0. 03 in the Maximum element size edit field, enter
1.2 in the Element growth rate edit field, and enter 0.1 in the Mesh curvature factor edit field.

3 Click OK.
4 Click the Initialize Mesh button on the Main toolbar.

COMPUTING THE SOLUTION

Click the Solve button on the Main toolbar to solve the model.

POSTPROCESSING AND VISUALIZATION

The quantities in the benchmark study are the drag and lift coefficients. These you can calculate easily
by integrating the weak constraint variables (which are really Lagrange multipliers corresponding to the
viscous forces) and the pressure over the surface of the cylinder. First calculate the drag coefficient:

1 From the Postprocessing menu, choose Boundary Integration.

2 Select boundaries 5 to 8, corresponding to the cylinder surface. Enter the drag force expression —
Iml1*2/ (rho0* (2*Umax/3) ~2*0.1) in the Expression edit field.

3 Click OK.

The result, 5.579384, appears in the message log and agrees well with the interval [5.57 5.59] given
in Ref. 1. Now calculate the lift coefficient.

4 Chan%e the inte8rand in the Expression edit field to —1m2*2/

> €L ) * (rhoO*(Z*Umax§3)A2*O.1}1.
Also this value, 0.010568, is in perfect agreement with Schéafer and Turek (Re the

f. 1), who give
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interval [0.0104 0.0110] for acceptable solutions.

Time-Dependent Simulation

Now that you know that the machinery works for low Reynolds numbers and steady flow, you can do a
time-dependent simulation at Re = 100.

OPTIONS AND SETTINGS

In the Constants dialog box change the maximum inflow velocity Umax to 1.5, corresponding to a
Reynolds number of 100.

COMPUTING THE SOLUTION

During the first seconds of the simulation, before the system reaches a state of steady periodic motion,
the output is not really interesting. Therefore you can save memory by saving only the value five times
per second up to 3.5 seconds, and then fifty times per second for another second and a half. Perform the
following steps for the time-dependent simulation of drag and lift:

From the Solve menu, choose Solver Parameters.

In the Solver list, select Time dependent.

Enter [0:0.2:3.5 3.52:0.02:7] in the Times edit field.

Enter 1e-4 in the Absolute tolerance edit field.

Click OK.

a 0 A W N =

Click the Solve button on the Main toolbar.

POSTPROCESSING AND VISUALIZATION

The difference from the former case can be seen immediately. Downstream of the cylinder, the Karman
path is clearly visible (see Figure 6-1 earlier in this discussion).

To see the evolution of the vortex trail from zero velocity until the flow is fully developed, click the
Animation button on the Plot toolbar on the left-hand side of the user interface. Notice that the time
scale of the movie changes after 3.5 seconds.

You can also investigate the forces on the tube as a function of time by assigning the surface integral to
a so-called integration-coupling variable:
1 Select the menu item Options>Integration Coupling Variables>Boundary Variables.

2 Ctrl-click boundaries 5 to 8 to select them as a group. Type Lift as the first Name item and -
1m2*2/ (rho0* (2*Umax/3) ~2*0.1) in the Expression edit field.

3 Clear the Global destination check box. This saves memory because you define the integral value
to be stored only in one node instead of all the nodes in the model.

4 Click the Destination tab and select point 1. Click OK.

Select the menu item Solve>Update Model. This calculates the integral without re-solving the
problem.

6 From the Postprocessing menu, select Domain Plot Parameters. Select all the time steps, then
click Plot type: Point plot. Go to the Point tab, select point 1, and type Lift in the Expression
edit field. The plot clearly shows the oscillations in the lift force.
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Figure 6-2: Time evolution of the total lift force on the cylinder.

Finally, you can investigate how suspended particles behave in the flow stream. Consider, for example,
small water droplets entering with the air flow.

In the Plot Parameters dialog box, go to the Particle Tracing page.

Select the Particle tracing plot check box.

In the Plot type list, select Points.

In the Predefined forces list, select the Khan and Richardson force (ns).

u b W N =

On the Start Points tab, enter 0 in the x edit field and then enter 0.1:0.05:0. 3 in the y edit
field.

6 Go to the Initial Values page. Clear the Auto check box and enter 3. 6 in the Start time edit field
to study the particles only for fully developed flow.

7 In the Initial velocity edit fields, enter u and v to give the particles the same initial velocity as the
inflow.

8 Go to the Point Settings page, find the When particles leaves the domain list, and select
Disappear.

9 On the Release page, select Time between releases and specify the time as 0. 4.
10 Click the Advanced button.

11 Select the Manual tuning of step size check box and enter 0. 02 in the Initial time step edit field
and 0.01 for Maximum time step.

12 Click OK to close the Advanced Parameters window.

13 Go to the Animate tab and click Start Animation. Remember that the time scale of the movie
changes after 3.5 seconds.
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